Автор Тема: XFCE 4.12 в Debian 8 Jessie  (Прочетена 3815 пъти)

ivoarch

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: stotinkaOS
  • Window Manager: GNOME, Ratpoison
    • Профил
    • WWW
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #15 -: Sep 22, 2015, 15:21 »
Само, че в хранилищата на CENTOS никога няма да има пакети за Xfce 4.12

+100%

Ето как е положението

* CentOS 5 - Xfce 4.4 (in CentOS Extras)
* CentOS 5 - Xfce 4.6 (based on Fedora 6)
* CentOS 6 - Xfce 4.8 (based on Fedora 12)
* CentOS 7 - Xfce 4.10 (based on Fedora 18)

CentOS 6
Правенето на пакет/и за Xfce 4.12 е доста сложна и без мислена задача , освен ако не си мазохист и обичаш да си губиш времето .

CentOS 7
Тук по има шанс да стане надграждане на Xfce 4.10 към 4.12 .

Като цяло надграждането на пакети е сложна задача, имайки предвид , че в повечето случаи се получава ефекта на доминото,  и счупиш ли един пакет ще трябва да компилираш куп пакети още. Също това е против цялата идея за Enterprise Linux който сам по себе си е предназначен да поддържа основните Apis през целият живот на една основна версия . Ето защо например в CentOS 6 винаги ще бъде версия 4.8 на XFCE , и в CentOS 7 винаги XFCE4.10 .

Цитат
Each major version of CentOS is designed to give you its major functionality that it comes with for 10 years. It is not designed to be cutting edge, it is designed to function like it did when you installed it for 10 years from the time it was released. That means if you are an ISP (or Facebook or Zynga) and you invested $1 Million dollars in writing software, you can know how long your software will be able to run before you have to invest to rewrite it for a new platform. You can't rewrite your software every 6 months when the latest version of Gnome is released. You need a solid, stable platform to run your code for a long time. That is Enterprise Linux.

Активен

Head Banger..

cybercop

  • Напреднали
  • *****
  • Публикации: 5578
  • Distribution: Ubuntu LTS, CENTOS 6.x
  • Window Manager: Xfce, Gnome 2
    • Профил
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #16 -: Sep 22, 2015, 16:29 »
Имах предвид само шестицата, защото CENTOS 7 и инсталирах и премахнах след няколко часа. Изобщо не ми вдъхна доверие с този измислен десктоп.
Xfce във Fedora е в доста добро състояние, но пък доста неща не са в последната версия с псевдопреминаването към DNF. Изобщо, доста пъти съм се чудил, Fedora за каква дистрибуция да я броя. Уж се води с фиксиран и при това много кратък срок на поддръжка, а в доста отношения се отклонява от този модел, като в рамките на този срок се надграждат ключови пакети, като ядрото например.
« Последна редакция: Sep 22, 2015, 16:32 от cybercop »
Активен

Ползването на Linux води до пристрастяване. Факт.
http://s19.postimg.cc/4oajwoq5v/xenial2.png

Naka

  • Напреднали
  • *****
  • Публикации: 2795
    • Профил
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #17 -: Sep 23, 2015, 20:16 »
 Аз явно съм мазохист щото вече сложих  Xfce 4.12 под  Centos6. Процесът на компилиране изобщо не се указа толкова сложен колкото си мислех. Всичко вървеше много гладко и изключително бързо. Тъй че въобще не се плашете от компилиране на xfce.   Явно е много качествен софтуер.

Начина на компилиране е много добре и точно описан тук. http://docs.xfce.org/xfce/building

Трябва точно да се спазва кое след кое да се билдва.  И да се зададе
Код:
export PKG_CONFIG_PATH="${PREFIX}/lib/pkgconfig:$PKG_CONFIG_PATH"
Например ако ще се инсталира в /opt/xfce
с
.configure --prefix=/opt/xfce
Пътя трябва да стане такА
export PKG_CONFIG_PATH="/opt/xfce/lib/pkgconfig:$PKG_CONFIG_PATH"

Имаше и 4-5 библиотеки за които нямаше необходимите минимални версии в Ц6. Тях ги взех от Ц7 (и една федора)  като *.src.rpm и ги ребилднах под 6-ицата.

Та така....


« Последна редакция: Sep 23, 2015, 20:36 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

ivoarch

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: stotinkaOS
  • Window Manager: GNOME, Ratpoison
    • Профил
    • WWW
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #18 -: Sep 24, 2015, 12:18 »
Аз явно съм мазохист щото вече сложих  Xfce 4.12 под  Centos6. Процесът на компилиране изобщо не се указа толкова сложен колкото си мислех. Всичко вървеше много гладко и изключително бързо. Тъй че въобще не се плашете от компилиране на xfce.   Явно е много качествен софтуер.



Защо тогава не направиш едно хранилище за EL6 - Xfce 4.12  в което да влизат всички нужни зависимости , и самото Xfce4.12 ?
Така ще си по полезен, отколкото само да ни казваш колко лесно се компилирало.
Активен

Head Banger..

Naka

  • Напреднали
  • *****
  • Публикации: 2795
    • Профил
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #19 -: Sep 24, 2015, 12:45 »
Да лесно се компилира....Обаче правенето на РПМ пакети вече наистина е мазохизъм. Затова и предложих да се инсталира в /opt/xfce да е по независимо от /usr и да не станат поразии ако някой си инсталира отгоре стабдартен пакет на xfce от дистрото.
Активен

Perl - the only language that looks the same before and after encryption.

ivoarch

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: stotinkaOS
  • Window Manager: GNOME, Ratpoison
    • Профил
    • WWW
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #20 -: Sep 24, 2015, 12:52 »
Да лесно се компилира....Обаче правенето на РПМ пакети вече наистина е мазохизъм. Затова и предложих да се инсталира в /opt/xfce да е по независимо от /usr и да не станат поразии ако някой си инсталира отгоре стабдартен пакет на xfce от дистрото.
Аз точно това имах предвид под мазохизъм.  Има библиотеки като Glib2 които са от @base и искат надграждане, което не е никак добра идея, не се знае какво може да се счупи по системата. 

edit: Може и да се направят, но не знам дали ще си струва, целият труд за нещо подобно.
« Последна редакция: Sep 24, 2015, 12:54 от ivoarch »
Активен

Head Banger..

Naka

  • Напреднали
  • *****
  • Публикации: 2795
    • Профил
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #21 -: Sep 24, 2015, 13:21 »
Аз точно това и направих ъпгрейднах с glib2-2.28.8-4 с glib2-2.40.0-4.el6.i686.rpm (rebuild отЦ7)

нищо не се е счупило и всичко работи.
би трябвало за библиотеката щом major номера е същият 2 а има смамо промяна в минорния 28->40 да е съвместима надолу???

-------
Сега има един въпрос който продължава да ме мъчи?
ако се направи rpm -Fvh  glib2-2.40.0-4.el6.i686.rpm това ще затърка текущата библиотека  glib2-2.28,
но ако се изсталира с glib2-2.40 с ./configure make make install това запазва старата, добаявя и новата и ъпдейтва линковете. та ако има някоя програма която да линкната с още старата тя ще продължи да си я използва..........

Та кой е правилният подход.


« Последна редакция: Sep 24, 2015, 13:26 от Naka »
Активен

Perl - the only language that looks the same before and after encryption.

ivoarch

  • Напреднали
  • *****
  • Публикации: 23
  • Distribution: stotinkaOS
  • Window Manager: GNOME, Ratpoison
    • Профил
    • WWW
Re: XFCE 4.12 в Debian 8 Jessie
« Отговор #22 -: Sep 24, 2015, 14:27 »
Актуализирането на GLib през RPM го изключи, не  е никак добра идея, тъй като гаранция ще има щети за в бъдеще.
Единствения по сигурен начин, е да се инсталира Glib от сорс,  в изолирано местоположение в системата.

Да обаче нас ни интересува всичко да става възможно най лесно и през RPM, така че може в някои .spec файл на XFCE4.12 се добави всичко нужно за буилдването на GLIB новата версия ,  един много добър пример как да стане това, е пакета за gim28 , в който всички нужни надграждащи библиотеки са забити в .spec файла , може да видиш сорса от тук [1] https://www.dropbox.com/sh/9dt7klam6ex1kpp/MONq7bnIRZ/20131005/gimp28-2.8.6-1.el6.src.rpm?dl=1 обърни внимание на .spec файла .  Отново там може да прочетеш как става цялата хитрина с GLIB и повече по въпроса [1] http://nuxref.com/2013/10/05/gimp-v2-8-on-centos-6/ .

edit: Относно major номера, не разчитай на тази логика.
« Последна редакция: Sep 24, 2015, 14:30 от ivoarch »
Активен

Head Banger..