Автор Тема: Slackware - гаден проблем със звука  (Прочетена 1422 пъти)

ThunderLizard

  • Участници
  • ***
  • Публикации: 9
    • Профил
Със Slackware 9.1 съм и всичко работи чудесно, но когато се случи едновременно да идва звук от две места (например от Licq и XMMS или XMMS и Mplayer), се получава един вид изчакване между приложенията. Примерно Licq пищи в паузите между песните, свирени от XMMS, а ако слушам или съм слушал Mp3-ка допреди минута с XMMS и пусна филм с Мplayer, той ми връща следното:

Примерен код
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
audio_setup: Can't open audio device /dev/dsp: Device or resource busy
alsa-init: testing and bugreports are welcome.
alsa-init: requested format: 48000 Hz, 2 channels, Signed 16-bit (Little-Endian)
alsa-init: 1 soundcard found, using: hw:0,0


И така...въпросът ми е дали не може някак да се настрои звуковата карта да работи паралелно с няколко приложения...става дума за АС97 onboard audio.

Благодаря предварително на всички '<img'>
Активен

  • Гост
Slackware - гаден проблем със звука
« Отговор #1 -: Mar 20, 2005, 10:07 »
Ползва ли ТЪРСАЧКАТА преди да питаш '<img'>
Активен

ThunderLizard

  • Участници
  • ***
  • Публикации: 9
    • Профил
Slackware - гаден проблем със звука
« Отговор #2 -: Mar 20, 2005, 10:40 »
Цитат (Guest @ Март 20 2005,11:07)
Ползва ли ТЪРСАЧКАТА преди да питаш '<img'>

10x '<img'> мина ми през ума да я ползвам, но нямах идея точно за какво да търся...не очаквах, че ще даде резултат  '<img'> Досега с нея съм дейставал, ще я имам предвид и занапред...
Активен

sebastianz55

  • Напреднали
  • *****
  • Публикации: 1136
    • Профил
    • WWW
Slackware - гаден проблем със звука
« Отговор #3 -: Mar 20, 2005, 11:12 »
Ами тъй като виждам, че щом те насочват към търсачката разбирам, че не си чел павилата. А това е голям пропуск - коригирай го веднага.
Активен

С уважения:
Sebastianz55
------------------
http://www.fsa-bg.org
                              
Open Fest Initiative  http://openfest.org
                                              
Моля ви, уважавайте процесорното време на другите - пишете на кирилица и използвайте търсачката на форума!

  • Гост
Slackware - гаден проблем със звука
« Отговор #4 -: Mar 20, 2005, 12:41 »
Alsata si raboti perfektno no kogato sound servera na kdeto se inicializira prosto si ebawa mamata

Reshenie ot Control Panela na kdeto w sound imashe mai sound server i se zabranqwa togawa zwukowata karta baca prosto perfektno

az sum s sushtata gadost i oshe me e qd che si shitnah creative-a
Активен

sys7em

  • Напреднали
  • *****
  • Публикации: 401
    • Профил
    • WWW
Slackware - гаден проблем със звука
« Отговор #5 -: Mar 20, 2005, 13:21 »
Написал сам статия по тоя въпрос::
http://www.linux-bg.org/cgi-bin....9693711
Активен

Европейци сме ний, ама все не сме дотам!. . . Прощавай, не е за чудо пак да се срещнем.

Swetko

  • Напреднали
  • *****
  • Публикации: 21
    • Профил
Slackware - гаден проблем със звука
« Отговор #6 -: Jun 23, 2005, 17:06 »
но аз въобще нямам такива файлове.
При мен в гном не ми тръгва изобщо ХММС,  а в КДЕ тръгна и по едно време почна да казва че друга програма блокира саункартата
Активен

  • Гост
Slackware - гаден проблем със звука
« Отговор #7 -: Jun 29, 2005, 23:55 »
изпълних инструкциите от онази статия но пак не става.
ХММС не иска да свири като казва че звуковата карта е използвана от друга програма. песните вървят през тотем плейър, даже имам и звуци в ГНОМЕ едновременно, но други програми не искат да свирят нищо. ХММС е нагласен на алса.

И също така когато ГНОМЕ издава звуци с включен тотем плеър те са леко забавени - с около положин секунда, а иначе навреме се свирят.
Активен

philip

  • Напреднали
  • *****
  • Публикации: 207
    • Профил
Slackware - гаден проблем със звука
« Отговор #8 -: Jul 02, 2005, 01:53 »
Кажи на xmms да ползва esd
Активен

Invincible

  • Напреднали
  • *****
  • Публикации: 115
    • Профил
Slackware - гаден проблем със звука
« Отговор #9 -: Jul 02, 2005, 14:05 »
Ако си на Gnome пробвай Beep Media Player - еквивалент на XMMS - От там даваш да използва ALSA и готово '<img'>
Активен

Аз съм българче обичам нашите планини зелени и да пиша на кирилица е чест за мен.

Swetko

  • Напреднали
  • *****
  • Публикации: 21
    • Профил
Slackware - гаден проблем със звука
« Отговор #10 -: Jul 13, 2005, 12:00 »
сложих esd  и   вече ХММС свири но реакциите на звуковата карта са малко бавни. като дам някоя песен да се свири почва след половин секунда, като я спра спира след положин секунда, другите звуци които са от ГНОМ също се забавят. Малко е дразнещо това.
Активен

PAIN1

  • Напреднали
  • *****
  • Публикации: 432
    • Профил
Slackware - гаден проблем със звука
« Отговор #11 -: Jul 16, 2005, 10:40 »
оффтопик

аз със слак 10.1 доста време бях с ЕСД-то и един чудесен ден почна да ме дразни някакво пращане, какво ли не опитах, накрая се оказа че е ЕСД-то, а сега деца кажете ?
mplayer с есд-то пак пращи леко .........  ?
без него не пращи, това някак си от самосебеси стана .
Активен

philip

  • Напреднали
  • *****
  • Публикации: 207
    • Профил
Slackware - гаден проблем със звука
« Отговор #12 -: Jul 16, 2005, 16:54 »
пробвай опцията -r 48 000
Активен

Подобни теми
Заглавие Започната от Отговора Прегледи Последна публикация
Slackware QT проблем
Настройка на програми
kikcho 1 2383 Последна публикация Nov 11, 2002, 08:48
от mrvoland
Обновяване към Slackware 9.0
Хардуерни и софтуерни проблеми
FreeJak 3 2311 Последна публикация Mar 25, 2003, 00:53
от FreeJak
Slackware
Настройка на програми
ivo3d 1 1814 Последна публикация Mar 27, 2003, 23:53
от ivo3d
Slackware 9.0
Хардуерни и софтуерни проблеми
ivo3d 3 1971 Последна публикация Apr 07, 2003, 03:48
от ivo3d
Slackware 8.1
Настройка на програми
rip_darkman 1 2012 Последна публикация Aug 21, 2003, 08:59
от dafo